Back to overview
Degraded
Experiencing higher latencies
Jun 11, 2026 at 1:13am UTC
Affected services
api.supermemory.ai
Resolved
Jun 11, 2026 at 1:33am UTC
this issue has been fixed
Affected services
Updated
Jun 11, 2026 at 1:23am UTC
we have identified the issue and working on fix
Affected services
Created
Jun 11, 2026 at 1:13am UTC
we are investigating right now
Affected services